<!DOCTYPE html><html lang="en-US"><head><meta name="google-site-verification" content="ba0RDBgV3sh3Y1wm4nh0fHj8hpOmpzahLK_SNp30fAU" /><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><meta http-equiv="X-UA-Compatible" content="IE=edge"><meta name="HandheldFriendly" content="true"><link rel="profile" href="http://gmpg.org/xfn/11"><link href="https://fonts.googleapis.com/css?family=Roboto+Slab:400,700|Roboto:400,400i,700,700i" as="style" onload="this.onload=null;this.rel='stylesheet'" rel="preload"><title>Amy Dorris’ Friend Says Accusations Against Trump Not Motivated</title><style id="rocket-critical-css">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</style><link rel="preload" href="https://powdersvillepost.com/wp-content/cache/min/1/d8cae8fb577e578b1f6d3bfda7d626f0.css" as="style" onload="this.onload=null;this.rel='stylesheet'" data-minify="1" /><meta name="description" content="Caron Bernstein, a former top model, came out in support of her friend Amy Dorris who has accused President Donald Trump" /><meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://powdersvillepost.com/amy-dorris-friend-says-accusations-against-trump-not-motivated-by-politics/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Amy Dorris’ Friend Says Accusations Against Trump Not Motivated" /><meta property="og:description" content="Caron Bernstein, a former top model, came out in support of her friend Amy Dorris who has accused President Donald Trump" /><meta property="og:url" content="https://powdersvillepost.com/amy-dorris-friend-says-accusations-against-trump-not-motivated-by-politics/" /><meta property="og:site_name" content="Powdersville Post" /><meta property="article:published_time" content="2020-09-19T10:45:14+00:00" /><meta property="article:modified_time" content="2020-09-19T13:30:15+00:00" /><meta property="og:image" content="https://powdersvillepost.com/wp-content/uploads/2020/09/Amy-Dorris-friend-says-accusations-against-Trump-not-motivated-by-politics.jpg" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="800" /><meta name="twitter:card" content="summary_large_image" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://powdersvillepost.com/#organization","name":"Powdersvillepost.com","url":"https://powdersvillepost.com/","sameAs":[],"logo":{"@type":"ImageObject","@id":"https://powdersvillepost.com/#logo","inLanguage":"en-US","url":"","caption":"Powdersvillepost.com"},"image":{"@id":"https://powdersvillepost.com/#logo"}},{"@type":"WebSite","@id":"https://powdersvillepost.com/#website","url":"https://powdersvillepost.com/","name":"Powdersville Post","description":"Complete World News","publisher":{"@id":"https://powdersvillepost.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://powdersvillepost.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://powdersvillepost.com/amy-dorris-friend-says-accusations-against-trump-not-motivated-by-politics/#primaryimage","inLanguage":"en-US","url":"https://powdersvillepost.com/wp-content/uploads/2020/09/Amy-Dorris-friend-says-accusations-against-Trump-not-motivated-by-politics.jpg","width":1200,"height":800,"caption":"Amy Dorris\u2019 friend says accusations against Trump not motivated by politics"},{"@type":"WebPage","@id":"https://powdersvillepost.com/amy-dorris-friend-says-accusations-against-trump-not-motivated-by-politics/#webpage","url":"https://powdersvillepost.com/amy-dorris-friend-says-accusations-against-trump-not-motivated-by-politics/","name":"Amy Dorris\u2019 Friend Says Accusations Against Trump Not Motivated","isPartOf":{"@id":"https://powdersvillepost.com/#website"},"primaryImageOfPage":{"@id":"https://powdersvillepost.com/amy-dorris-friend-says-accusations-against-trump-not-motivated-by-politics/#primaryimage"},"datePublished":"2020-09-19T10:45:14+00:00","dateModified":"2020-09-19T13:30:15+00:00","description":"Caron Bernstein, a former top model, came out in support of her friend Amy Dorris who has accused President Donald Trump","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://powdersvillepost.com/amy-dorris-friend-says-accusations-against-trump-not-motivated-by-politics/"]}]},{"@type":"Article","@id":"https://powdersvillepost.com/amy-dorris-friend-says-accusations-against-trump-not-motivated-by-politics/#article","isPartOf":{"@id":"https://powdersvillepost.com/amy-dorris-friend-says-accusations-against-trump-not-motivated-by-politics/#webpage"},"author":{"@id":"https://powdersvillepost.com/#/schema/person/932c50ca2e41870ea3fdabdad1af318a"},"headline":"Amy Dorris\u2019 Friend Says Accusations Against Trump Not Motivated By Politics","datePublished":"2020-09-19T10:45:14+00:00","dateModified":"2020-09-19T13:30:15+00:00","mainEntityOfPage":{"@id":"https://powdersvillepost.com/amy-dorris-friend-says-accusations-against-trump-not-motivated-by-politics/#webpage"},"commentCount":0,"publisher":{"@id":"https://powdersvillepost.com/#organization"},"image":{"@id":"https://powdersvillepost.com/amy-dorris-friend-says-accusations-against-trump-not-motivated-by-politics/#primaryimage"},"articleSection":"Top News","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://powdersvillepost.com/amy-dorris-friend-says-accusations-against-trump-not-motivated-by-politics/#respond"]}]},{"@type":"Person","@id":"https://powdersvillepost.com/#/schema/person/932c50ca2e41870ea3fdabdad1af318a","name":"Nikki Attkisson","image":{"@type":"ImageObject","@id":"https://powdersvillepost.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/a64d247b5c0631f6ea7ed1d097a234a5?s=96&d=mm&r=g","caption":"Nikki Attkisson"},"description":"With over 15 years as a practicing journalist, Nikki Attkisson found herself at Powdersville Post now after working at several other publications. She is an award-winning journalist with an entrepreneurial spirit and worked as a journalist covering technology, innovation, environmental issues, politics, etc. Nikki Attkisson has also worked on product development, content strategy, and editorial management for numerous media companies. Her investigative works exposed to child sex-trafficking and environmental issues. She began her career at local news stations and worked as a reporter in national newspapers."}]}</script> <link rel='dns-prefetch' href='//c0.wp.com' /><link rel="alternate" type="application/rss+xml" title="Powdersville Post &raquo; Feed" href="https://powdersvillepost.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Powdersville Post &raquo; Comments Feed" href="https://powdersvillepost.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Powdersville Post &raquo; Amy Dorris’ Friend Says Accusations Against Trump Not Motivated By Politics Comments Feed" href="https://powdersvillepost.com/amy-dorris-friend-says-accusations-against-trump-not-motivated-by-politics/feed/" /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link rel='preload' id='wp-block-library-css' href='https://c0.wp.com/c/5.5.1/wp-includes/css/dist/block-library/style.min.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><style id='wp-block-library-inline-css' type='text/css'>.has-text-align-justify{text-align:justify}</style><link rel='preload' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/8.9.1/css/jetpack.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' />  <link rel="https://api.w.org/" href="https://powdersvillepost.com/wp-json/" /><link rel="alternate" type="application/json" href="https://powdersvillepost.com/wp-json/wp/v2/posts/3289" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://powdersvillepost.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://powdersvillepost.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.5.1" /><link rel='shortlink' href='https://powdersvillepost.com/?p=3289' /><link rel="alternate" type="application/json+oembed" href="https://powdersvillepost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fpowdersvillepost.com%2Famy-dorris-friend-says-accusations-against-trump-not-motivated-by-politics%2F" /><link rel="alternate" type="text/xml+oembed" href="https://powdersvillepost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fpowdersvillepost.com%2Famy-dorris-friend-says-accusations-against-trump-not-motivated-by-politics%2F&#038;format=xml" />  <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-165589521-1', 'auto');
			ga('send', 'pageview');</script>  <script async src="https://www.googletagmanager.com/gtag/js?id=UA-166052615-1"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-166052615-1');</script> <meta name="google-site-verification" content="xDsrGyXHueRMgbz4Bde1EPjCs7S8Tx9MBbQ5f8a2AjY" />   <style type='text/css'>img#wpstats{display:none}</style><link rel="pingback" href="https://powdersvillepost.com/xmlrpc.php"><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript><script>/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))</script> </head><body class="post-template-default single single-post postid-3289 single-format-standard group-blog"><div id="page" class="site"><header id="masthead" class="site-header clear"><div id="top-bar" class="clear"><div class="container"><nav id="primary-nav" class="main-navigation"></nav> <span class="header-social"> </span></div></div><div class="site-start container clear"><div class="site-branding"><div id="logo"> <span class="helper"></span> <a href="https://powdersvillepost.com/" rel="home"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" data-lazy-src="https://powdersvillepost.com/wp-content/uploads/2020/06/powdersville-post-logo-site-01.png"/><noscript><img src="https://powdersvillepost.com/wp-content/uploads/2020/06/powdersville-post-logo-site-01.png" alt=""/></noscript> </a></div></div> <span class="mobile-menu-icon"> <span class="menu-icon-open">Menu</span> <span class="menu-icon-close"><span class="genericon genericon-close"></span></span> </span></div><div id="secondary-bar" class="container clear"><nav id="secondary-nav" class="secondary-navigation"><div class="menu-primary-menu-container"><ul id="secondary-menu" class="sf-menu"><li id="menu-item-524" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-524"><a href="https://powdersvillepost.com/">Home</a></li><li id="menu-item-517" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-517"><a href="https://powdersvillepost.com/economy/">Economy</a></li><li id="menu-item-518" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-518"><a href="https://powdersvillepost.com/entertainment/">entertainment</a></li><li id="menu-item-519" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-519"><a href="https://powdersvillepost.com/politics/">Politics</a></li><li id="menu-item-520" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-520"><a href="https://powdersvillepost.com/sport/">Sport</a></li><li id="menu-item-521" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-521"><a href="https://powdersvillepost.com/tech/">Tech</a></li><li id="menu-item-522" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-522"><a href="https://powdersvillepost.com/top-news/">Top News</a></li><li id="menu-item-523" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-523"><a href="https://powdersvillepost.com/world/">World</a></li></ul></div></nav> <span class="search-icon"> <span class="genericon genericon-search"></span> <span class="genericon genericon-close"></span> </span><div class="header-search"><form id="searchform" method="get" action="https://powdersvillepost.com/"> <input type="search" name="s" class="search-input" placeholder="Search for..." autocomplete="off"> <button type="submit" class="search-submit">Search</button></form></div></div><div class="mobile-menu clear"><div class="container"><div class="menu-left"><h3>Pages</h3></div><div class="menu-right"><h3>Categories</h3><div class="menu-primary-menu-container"><ul id="secondary-mobile-menu" class=""><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-524"><a href="https://powdersvillepost.com/">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-517"><a href="https://powdersvillepost.com/economy/">Economy</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-518"><a href="https://powdersvillepost.com/entertainment/">entertainment</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-519"><a href="https://powdersvillepost.com/politics/">Politics</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-520"><a href="https://powdersvillepost.com/sport/">Sport</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-521"><a href="https://powdersvillepost.com/tech/">Tech</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-522"><a href="https://powdersvillepost.com/top-news/">Top News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-523"><a href="https://powdersvillepost.com/world/">World</a></li></ul></div></div></div></div></header><div class="header-space"></div><div id="content" class="site-content container clear"><div id="primary" class="content-area"><div class="breadcrumbs clear"><h1> <a href="https://powdersvillepost.com/">Home</a> &rarr; <a href="https://powdersvillepost.com/top-news/" title="View all posts in Top News" >Top News</a></h1></div><main id="main" class="site-main" ><article id="post-3289" class="post-3289 post type-post status-publish format-standard has-post-thumbnail hentry category-top-news"><header class="entry-header"><h1 class="entry-title">Amy Dorris’ Friend Says Accusations Against Trump Not Motivated By Politics</h1><div class="entry-meta clear"> <span class="entry-author"><a href="https://powdersvillepost.com/author/nikki-attkisson/"><img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2048%2048'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/a64d247b5c0631f6ea7ed1d097a234a5?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' loading='lazy' data-lazy-src="https://secure.gravatar.com/avatar/a64d247b5c0631f6ea7ed1d097a234a5?s=48&#038;d=mm&#038;r=g"/><noscript><img alt='' src='https://secure.gravatar.com/avatar/a64d247b5c0631f6ea7ed1d097a234a5?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/a64d247b5c0631f6ea7ed1d097a234a5?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' loading='lazy'/></noscript></a> Posted by <a href="https://powdersvillepost.com/author/nikki-attkisson/" title="Posts by Nikki Attkisson" rel="author">Nikki Attkisson</a></span> &#8212; <span class="entry-date">September 19, 2020</span> <span class="entry-category"> in <a href="https://powdersvillepost.com/top-news/" title="View all posts in Top News" >Top News</a> </span> <span class="entry-comment-number"><a href="https://powdersvillepost.com/amy-dorris-friend-says-accusations-against-trump-not-motivated-by-politics/#respond" class="comments-link" >0</a></span></div><div class="share-icons"> <a class="twitter" href="https://twitter.com/intent/tweet?text=Amy+Dorris%E2%80%99+Friend+Says+Accusations+Against+Trump+Not+Motivated+By+Politics&amp;url=https%3A%2F%2Fpowdersvillepost.com%2Famy-dorris-friend-says-accusations-against-trump-not-motivated-by-politics%2F" target="_blank"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" data-lazy-src="https://powdersvillepost.com/wp-content/themes/makemoney-pro/assets/img/icon-twitter-white.png"/><noscript><img src="https://powdersvillepost.com/wp-content/themes/makemoney-pro/assets/img/icon-twitter-white.png" alt=""/></noscript><span>Share on </span>Twitter</a> <a class="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fpowdersvillepost.com%2Famy-dorris-friend-says-accusations-against-trump-not-motivated-by-politics%2F" target="_blank"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" data-lazy-src="https://powdersvillepost.com/wp-content/themes/makemoney-pro/assets/img/icon-facebook-white.png"/><noscript><img src="https://powdersvillepost.com/wp-content/themes/makemoney-pro/assets/img/icon-facebook-white.png" alt=""/></noscript><span>Share on </span>Facebook</a> <a class="google-plus" href="https://plus.google.com/share?url=https%3A%2F%2Fpowdersvillepost.com%2Famy-dorris-friend-says-accusations-against-trump-not-motivated-by-politics%2F" target="_blank"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" data-lazy-src="https://powdersvillepost.com/wp-content/themes/makemoney-pro/assets/img/icon-google-plus-white.png"/><noscript><img src="https://powdersvillepost.com/wp-content/themes/makemoney-pro/assets/img/icon-google-plus-white.png" alt=""/></noscript><span>Share on </span>Google+</a></div></header><div class="entry-content"><p>Caron Bernstein, a former top model, came out in support of her friend Amy Dorris who has accused President Donald Trump of sexually assaulting her years ago. She said that Amy Dorris did not come out in public due to political motives, and it just happened.</p><p><img loading="lazy" class="size-full wp-image-3290 aligncenter" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201200%20800'%3E%3C/svg%3E" alt="Amy Dorris’ friend says accusations against Trump not motivated by politics" width="1200" height="800" data-lazy-srcset="https://powdersvillepost.com/wp-content/uploads/2020/09/Amy-Dorris-friend-says-accusations-against-Trump-not-motivated-by-politics.jpg 1200w, https://powdersvillepost.com/wp-content/uploads/2020/09/Amy-Dorris-friend-says-accusations-against-Trump-not-motivated-by-politics-300x200.jpg 300w, https://powdersvillepost.com/wp-content/uploads/2020/09/Amy-Dorris-friend-says-accusations-against-Trump-not-motivated-by-politics-1024x683.jpg 1024w, https://powdersvillepost.com/wp-content/uploads/2020/09/Amy-Dorris-friend-says-accusations-against-Trump-not-motivated-by-politics-768x512.jpg 768w" data-lazy-sizes="(max-width: 1200px) 100vw, 1200px" data-lazy-src="https://powdersvillepost.com/wp-content/uploads/2020/09/Amy-Dorris-friend-says-accusations-against-Trump-not-motivated-by-politics.jpg" /><noscript><img loading="lazy" class="size-full wp-image-3290 aligncenter" src="https://powdersvillepost.com/wp-content/uploads/2020/09/Amy-Dorris-friend-says-accusations-against-Trump-not-motivated-by-politics.jpg" alt="Amy Dorris’ friend says accusations against Trump not motivated by politics" width="1200" height="800" srcset="https://powdersvillepost.com/wp-content/uploads/2020/09/Amy-Dorris-friend-says-accusations-against-Trump-not-motivated-by-politics.jpg 1200w, https://powdersvillepost.com/wp-content/uploads/2020/09/Amy-Dorris-friend-says-accusations-against-Trump-not-motivated-by-politics-300x200.jpg 300w, https://powdersvillepost.com/wp-content/uploads/2020/09/Amy-Dorris-friend-says-accusations-against-Trump-not-motivated-by-politics-1024x683.jpg 1024w, https://powdersvillepost.com/wp-content/uploads/2020/09/Amy-Dorris-friend-says-accusations-against-Trump-not-motivated-by-politics-768x512.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /></noscript></p><p>Bernstein said that Dorris did not have any political agenda behind the timing of the allegations, and she had been with Dorris through the decision and interviews that were given to The Guardian. Dorris became friends with C<a href="https://news.mit.edu/2020/aron-bernstein-professor-emeritus-physics-dies-0203">aron Bernstein</a> in 2008, and she has always supported her to come out in public about the assault. Caron Bernstein is a former top model, and her husband is a good friend of Dorris. Dorris first told Bernstein&#8217;s husband about the assault in 1997. Bernstein is also a rape survivor, and she became good friends with Dorris after being introduced by her husband.</p><p>Bernstein is a spokeswoman for the Humans of Fashion Foundation that aims to protect workers in the fashion industry from abuse. She said that the MeToo movement was a huge inspiration for Dorris to come forward with her story. She also said that Dorris did not have any connections with the other women who had accused Trump similarly before the story was published. Dorris suffered from high fever and strep throat before the story broke recently and the stress of the imminent publication of her story lead to this, according to her friend. Bernstein said that she tried to get in touch as the story broke and also warned Dorris not to go on Twitter as supporters of Trump were likely to blast her for the story. Dorris is currently in seclusion and avoiding the media as she tries to regain her health.</p><p>Bernstein said that this is a huge relief for Dorris, and it has empowered her in many ways. Dorris is a mother of 13-year-old twin daughters, and she was aware of the backlash that would come from supporters of Donald Trump. She also understood that reporters would pursue her, and her motives, along with the timing, will be questioned by everyone. The alleged incident happened on September 5, 1997, in the VIP box at the US Open in New York. Dorris was 24 years old at that time, and Donald Trump was 51. She said that when she went to the bathroom, Trump forced himself on her after a brief exchange of talks. She said that she asked him nervously to get away as Trump forced his tongue down her throat. She added that Trump touched her all over the body and held her tightly so that she could not escape.</p><p>Dorris said that she had informed her boyfriend about the incident soon after she came out, and he went to confront Trump at the event. Trump told her boyfriend that she was out of his league. Dorris alleges that her boyfriend was a friend of Trump, and she spent four days around Trump with her boyfriend during that time. Dorris has six photos with Trump along with the ticket stub to the event as per the reports available on Guardian. Trump has strongly denied the allegations through his lawyers and said that he had never abused or harassed Dorris. Such allegations have become common, especially during important political events, and many people see this as a politically motivated strategy by the opponents. This is not new to Donald Trump, and several models and others who have worked with him in the past have made similar allegations of sexual assault against him in the past. However, Trump has denied all such allegations in the past and continued to do the same thing even this time.</p><p>Even though many people support Trump considering the timing of such allegations, it is the loose talks of Trump that often get him into trouble with such incidents. He has made insensible comments about women in the past on multiple occasions, and this gives everyone an opportunity to talk about the allegations. Many people think that if he can talk in such a derogatory manner about women in public, his behavior in private may be worse, and they tend to believe in such allegations made by some women against Trump. Recently, he got into trouble when he said that some women were not his type when she accused him of sexual assault. Such insensitive statements by a President does not go down well even with some of his supporters. Trump should understand that it is necessary to maintain some dignity while talking about women in public, and he cannot get away with loose talks like a common citizen.</p><p>The opponents of Trump have not yet reacted to this news, and it is likely that they will try to gain the advantage of such incidents. Even though nothing is so far proved against Trump in the past in terms of such allegations about sexual assault, it has surely dented his image in public. It would be interesting to see what kind of impact this will have on the elections that are scheduled to be held in November. Earlier, Clinton faced such allegations, and this had a serious effect on his political career. However, Trump has been bold enough to take on such allegations, and he has always taken an aggressive stance when it comes to countering such allegations of sexual assault.</p><p>The interesting thing about all the allegations on Trump is that they have come to the limelight only in the last few years. Even though most of the alleged incidents happened way before he was into active politics, they came into media focus only in recent years. This gives rise to a lot of doubts as many supporters of Trump feel that they are mere attempts by the opponents to get him out of office. The supporters feel that opponents are using such cheap tricks to malign the image of Trump in public. Considering all these things, it would be interesting to see how this new allegation shapes up in the future.</p><p>&nbsp;</p><p>&nbsp;</p></div> <span class="entry-tags"> </span></article><div class="entry-footer"><div class="share-icons"> <a class="twitter" href="https://twitter.com/intent/tweet?text=Amy+Dorris%E2%80%99+Friend+Says+Accusations+Against+Trump+Not+Motivated+By+Politics&amp;url=https%3A%2F%2Fpowdersvillepost.com%2Famy-dorris-friend-says-accusations-against-trump-not-motivated-by-politics%2F" target="_blank"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" data-lazy-src="https://powdersvillepost.com/wp-content/themes/makemoney-pro/assets/img/icon-twitter-white.png"/><noscript><img src="https://powdersvillepost.com/wp-content/themes/makemoney-pro/assets/img/icon-twitter-white.png" alt=""/></noscript><span>Share on </span>Twitter</a> <a class="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fpowdersvillepost.com%2Famy-dorris-friend-says-accusations-against-trump-not-motivated-by-politics%2F" target="_blank"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" data-lazy-src="https://powdersvillepost.com/wp-content/themes/makemoney-pro/assets/img/icon-facebook-white.png"/><noscript><img src="https://powdersvillepost.com/wp-content/themes/makemoney-pro/assets/img/icon-facebook-white.png" alt=""/></noscript><span>Share on </span>Facebook</a> <a class="google-plus" href="https://plus.google.com/share?url=https%3A%2F%2Fpowdersvillepost.com%2Famy-dorris-friend-says-accusations-against-trump-not-motivated-by-politics%2F" target="_blank"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" data-lazy-src="https://powdersvillepost.com/wp-content/themes/makemoney-pro/assets/img/icon-google-plus-white.png"/><noscript><img src="https://powdersvillepost.com/wp-content/themes/makemoney-pro/assets/img/icon-google-plus-white.png" alt=""/></noscript><span>Share on </span>Google+</a></div></div><div class="entry-related clear"><h3>You May <span>Also Like</span></h3><div class="related-loop clear"><div class="hentry"> <a class="thumbnail-link" href="https://powdersvillepost.com/hurricane-sally-320000-still-without-power-death-toll-climbs/"><div class="thumbnail-wrap"> <img width="650" height="364" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20650%20364'%3E%3C/svg%3E" class="attachment-post_thumb size-post_thumb wp-post-image" alt="Hurricane Sally: 320000 Still Without Power, Death Toll Climbs" loading="lazy" data-lazy-src="https://powdersvillepost.com/wp-content/uploads/2020/09/Hurricane-Sally-320000-Still-Without-Power-Death-Toll-Climbs-650x364.jpg" /><noscript><img width="650" height="364" src="https://powdersvillepost.com/wp-content/uploads/2020/09/Hurricane-Sally-320000-Still-Without-Power-Death-Toll-Climbs-650x364.jpg" class="attachment-post_thumb size-post_thumb wp-post-image" alt="Hurricane Sally: 320000 Still Without Power, Death Toll Climbs" loading="lazy" /></noscript></div> </a><h2 class="entry-title"><a href="https://powdersvillepost.com/hurricane-sally-320000-still-without-power-death-toll-climbs/">Hurricane Sally: 320000 Still Without Power, Death Toll Climbs</a></h2></div><div class="hentry last"> <a class="thumbnail-link" href="https://powdersvillepost.com/hysterectomies-led-to-an-investigation-against-the-ice-facility/"><div class="thumbnail-wrap"> <img width="650" height="364" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20650%20364'%3E%3C/svg%3E" class="attachment-post_thumb size-post_thumb wp-post-image" alt="Hysterectomies Led To An Investigation Against The ICE Facility" loading="lazy" data-lazy-src="https://powdersvillepost.com/wp-content/uploads/2020/09/Hysterectomies-led-to-an-investigation-against-the-ICE-facility-650x364.jpg" /><noscript><img width="650" height="364" src="https://powdersvillepost.com/wp-content/uploads/2020/09/Hysterectomies-led-to-an-investigation-against-the-ICE-facility-650x364.jpg" class="attachment-post_thumb size-post_thumb wp-post-image" alt="Hysterectomies Led To An Investigation Against The ICE Facility" loading="lazy" /></noscript></div> </a><h2 class="entry-title"><a href="https://powdersvillepost.com/hysterectomies-led-to-an-investigation-against-the-ice-facility/">Hysterectomies Led To An Investigation Against The ICE Facility</a></h2></div><div class="hentry"> <a class="thumbnail-link" href="https://powdersvillepost.com/beijing-blamed-for-coronavirus-by-the-u-s-ambassador/"><div class="thumbnail-wrap"> <img width="650" height="364" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20650%20364'%3E%3C/svg%3E" class="attachment-post_thumb size-post_thumb wp-post-image" alt="Beijing blamed for coronavirus by the U.S. ambassador" loading="lazy" data-lazy-src="https://powdersvillepost.com/wp-content/uploads/2020/09/Beijing-blamed-for-coronavirus-by-the-U.S.-ambassador-650x364.jpg" /><noscript><img width="650" height="364" src="https://powdersvillepost.com/wp-content/uploads/2020/09/Beijing-blamed-for-coronavirus-by-the-U.S.-ambassador-650x364.jpg" class="attachment-post_thumb size-post_thumb wp-post-image" alt="Beijing blamed for coronavirus by the U.S. ambassador" loading="lazy" /></noscript></div> </a><h2 class="entry-title"><a href="https://powdersvillepost.com/beijing-blamed-for-coronavirus-by-the-u-s-ambassador/">Beijing Blamed For Coronavirus By The U.S. Ambassador</a></h2></div><div class="hentry last"> <a class="thumbnail-link" href="https://powdersvillepost.com/ez-battery-reconditioning-review/"><div class="thumbnail-wrap"> <img width="650" height="364" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20650%20364'%3E%3C/svg%3E" class="attachment-post_thumb size-post_thumb wp-post-image" alt="EZ Battery Reconditioning rEVIEW" loading="lazy" data-lazy-src="https://powdersvillepost.com/wp-content/uploads/2020/09/EZ-Battery-Reconditioning-rEVIEW-650x364.png" /><noscript><img width="650" height="364" src="https://powdersvillepost.com/wp-content/uploads/2020/09/EZ-Battery-Reconditioning-rEVIEW-650x364.png" class="attachment-post_thumb size-post_thumb wp-post-image" alt="EZ Battery Reconditioning rEVIEW" loading="lazy" /></noscript></div> </a><h2 class="entry-title"><a href="https://powdersvillepost.com/ez-battery-reconditioning-review/">EZ Battery Reconditioning Review &#8211; The Method &#038; Chemical Analysed!</a></h2></div></div></div><div class="author-box clear"> <a href="https://powdersvillepost.com/author/nikki-attkisson/"><img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20120%20120'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/a64d247b5c0631f6ea7ed1d097a234a5?s=240&#038;d=mm&#038;r=g 2x' class='avatar avatar-120 photo' height='120' width='120' loading='lazy' data-lazy-src="https://secure.gravatar.com/avatar/a64d247b5c0631f6ea7ed1d097a234a5?s=120&#038;d=mm&#038;r=g"/><noscript><img alt='' src='https://secure.gravatar.com/avatar/a64d247b5c0631f6ea7ed1d097a234a5?s=120&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/a64d247b5c0631f6ea7ed1d097a234a5?s=240&#038;d=mm&#038;r=g 2x' class='avatar avatar-120 photo' height='120' width='120' loading='lazy'/></noscript></a><div class="author-meta"><h4 class="author-name">About the Author: <span><a href="https://powdersvillepost.com/author/nikki-attkisson/">Nikki Attkisson</a></span></h4><div class="author-desc"> With over 15 years as a practicing journalist, Nikki Attkisson found herself at Powdersville Post now after working at several other publications. She is an award-winning journalist with an entrepreneurial spirit and worked as a journalist covering technology, innovation, environmental issues, politics, etc. Nikki Attkisson has also worked on product development, content strategy, and editorial management for numerous media companies. Her investigative works exposed to child sex-trafficking and environmental issues. She began her career at local news stations and worked as a reporter in national newspapers.</div></div></div><div id="comments" class="comments-area"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/amy-dorris-friend-says-accusations-against-trump-not-motivated-by-politics/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://powdersvillepost.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='3289' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="906ca40168" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="211"/></p></form></div></div></main></div><aside id="secondary" class="widget-area sidebar"><div id="search-4" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://powdersvillepost.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" /> </label> <input type="submit" class="search-submit" value="Search" /></form></div><div id="recent-posts-4" class="widget widget_recent_entries"><h2 class="widget-title">Recent Posts</h2><ul><li> <a href="https://powdersvillepost.com/spressio-review/">Spressio Review &#8211; Steal Keywords from Your Competitors</a></li><li> <a href="https://powdersvillepost.com/amy-dorris-friend-says-accusations-against-trump-not-motivated-by-politics/" aria-current="page">Amy Dorris’ Friend Says Accusations Against Trump Not Motivated By Politics</a></li><li> <a href="https://powdersvillepost.com/hurricane-sally-320000-still-without-power-death-toll-climbs/">Hurricane Sally: 320000 Still Without Power, Death Toll Climbs</a></li><li> <a href="https://powdersvillepost.com/hysterectomies-led-to-an-investigation-against-the-ice-facility/">Hysterectomies Led To An Investigation Against The ICE Facility</a></li><li> <a href="https://powdersvillepost.com/proven-weight-loss-customer-review/">ProVen Weight Loss Customer Reviews- A Pill that Worth the Hype!</a></li></ul></div><div id="nav_menu-5" class="widget widget_nav_menu"><div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-524"><a href="https://powdersvillepost.com/">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-517"><a href="https://powdersvillepost.com/economy/">Economy</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-518"><a href="https://powdersvillepost.com/entertainment/">entertainment</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-519"><a href="https://powdersvillepost.com/politics/">Politics</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-520"><a href="https://powdersvillepost.com/sport/">Sport</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-521"><a href="https://powdersvillepost.com/tech/">Tech</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-522"><a href="https://powdersvillepost.com/top-news/">Top News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-523"><a href="https://powdersvillepost.com/world/">World</a></li></ul></div></div><div id="text-2" class="widget widget_text"><div class="textwidget"><p>Also Read<a href="https://powdersvillepost.com/spressio-review/"> Spressio Review</a></p></div></div></aside></div><footer id="colophon" class="site-footer"><div class="clear"></div><div id="site-bottom" class="container clear"><div class="site-info"> &copy; 2020 <a href="https://powdersvillepost.com">Powdersville Post</a> - Theme by <a href="https://www.happythemes.com/" target="_blank">HappyThemes</a></div></div></footer></div><div id="back-top"> <a href="#top" title="Back to top"><span class="genericon genericon-collapse"></span></a></div>  <script type='text/javascript' id='ta_main_js-js-extra'>/* <![CDATA[ */ var thirsty_global_vars = {"home_url":"\/\/powdersvillepost.com","ajax_url":"https:\/\/powdersvillepost.com\/wp-admin\/admin-ajax.php","link_fixer_enabled":"yes","link_prefix":"go","link_prefixes":["recommends","go"],"post_id":"3289","enable_record_stats":"yes","enable_js_redirect":"yes","disable_thirstylink_class":""}; /* ]]> */</script>            <script type='text/javascript' src='https://stats.wp.com/e-202038.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.9.1',blog:'176911451',post:'3289',tz:'5.5',srv:'powdersvillepost.com'} ]);
	_stq.push([ 'clickTrackerInit', '176911451', '3289' ]);</script> <script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://powdersvillepost.com/wp-content/plugins/wp-rocket/assets/js/lazyload/12.0/lazyload.min.js"></script> <script src="https://powdersvillepost.com/wp-content/cache/min/1/d6a6b91795f28ca51e80d22cb665fc3d.js" data-minify="1" defer></script><noscript><link href="https://fonts.googleapis.com/css?family=Roboto+Slab:400,700|Roboto:400,400i,700,700i" rel="stylesheet"></noscript><noscript><link rel="stylesheet" href="https://powdersvillepost.com/wp-content/cache/min/1/d8cae8fb577e578b1f6d3bfda7d626f0.css" data-minify="1" /></noscript><noscript><link rel='stylesheet' id='wp-block-library-css' href='https://c0.wp.com/c/5.5.1/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/8.9.1/css/jetpack.css' type='text/css' media='all' /></noscript></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1600522217 -->